Data Processing is slow
Incident Report for Productsup
Resolved
This incident has been resolved.
Posted Jul 17, 2018 - 00:56 CEST
Investigating
Data Processing is currently slow because of too much load on our database. We are investigating the issue and will come back with more information once the issue is fixed.
Posted Jul 16, 2018 - 23:47 CEST
This incident affected: Data Processing.