Investigating a performance drop in our proxy service.
Incident Report for Productsup
Resolved
This incident has been resolved.
Posted Oct 09, 2018 - 17:52 CEST
Investigating
We noticed a performance drop in the Proxy Service and we're investigating.
Posted Oct 09, 2018 - 17:30 CEST
This incident affected: Proxy Service.