Job processing delayed
Incident Report for Productsup
Resolved
A network between at 7:11 CET has been resolved at 7:21 CET. All services operational.
Posted Jan 15, 2018 - 07:31 CET
Investigating
We're investigating why there's an service interruption processing data since 7:11 CET
Posted Jan 15, 2018 - 07:22 CET