Platform Availability
Incident Report for Productsup
Resolved
The availability problems have now been cleared up. We recognize the inconvenience this may cause and appreciate your patience as we work to restore access to our services. We will provide an update on resolution of this issue when available.
Posted Feb 22, 2021 - 04:07 CET
Investigating
We are currently investigating the issue.
Posted Feb 22, 2021 - 03:46 CET
This incident affected: Productsup Platform.