FTP Download Service Disruption

Incident Report for Productsup

Resolved

This incident has been resolved.
Posted Jan 21, 2026 - 16:57 CET

Monitoring

Incident: FTP Download Service Disruption
Status: Monitoring
Duration: ~30-60 minutes (ended 17:34 UTC)

Impact: Customers experienced failures when downloading files via FTP during this window.

Root Cause: Internal network maintenance window on FTP infrastructure resulted in connectivity issues affecting the service.

Resolution: Network changes were reverted and full service restored. The FTP fleet is currently operating normally with enhanced monitoring active.

What We're Doing:

- Continuous monitoring of FTP service health and network metrics
- Post-incident review to improve change management procedures for infrastructure maintenance

We apologize for the disruption and appreciate your patience.
Posted Jan 21, 2026 - 16:04 CET
This incident affected: FTP Service.