Platform stability issues

Incident Report for Productsup

Resolved

The issue affecting the platform has been resolved. Service has been restored and the platform is operating normally.

Our team will continue to monitor the systems to ensure ongoing stability and performance. We appreciate your patience while we worked to resolve this incident. Thank you for your understanding.
Posted Mar 12, 2026 - 12:32 CET

Monitoring

The issue was identified in the virtualization cluster and has been partially resolved.

The platform is now operational. Our team will continue to closely monitor the systems to ensure stability and complete resolution of the incident.
Posted Mar 12, 2026 - 11:33 CET

Investigating

We are currently experiencing issues with the platform. Our team is actively investigating the problem and working to identify the root cause.

We will provide further updates as soon as more information becomes available.
Posted Mar 12, 2026 - 10:47 CET
This incident affected: Productsup Platform.