Performance Issues
Incident Report for Productsup
Resolved
The issue has been identified as a database lock. The lock has been removed and the user interface should continue working as usual. Thanks for your patience and continued support.
Posted Jul 26, 2023 - 21:39 CEST
Investigating
We're seeing slow responses for the Platform user interface. Data Processing is not affected. We are currently investigating the issue.

Sorry for the inconvenience.
Posted Jul 26, 2023 - 21:37 CEST
This incident affected: Productsup Platform.