This note confirms that the incident regarding slow response times in the Platform's user interface has been resolved.
Our engineering team successfully identified and addressed the underlying cause of the performance degradation. We have verified that the user interface is now responding normally.
Thank you for your patience and understanding while we worked to restore full service. Your Productsup Network Operations Team
Posted Jun 24, 2025 - 20:14 CEST
Monitoring
Dear customers,
We have rerouted internal traffic by another route, which caused drastic improvements in platform load times.
We will continue to monitor the situation and resolve this incident when fully satisfied.
Thanks for your patience, Your Productsup Network Operations Team
Posted Jun 24, 2025 - 18:22 CEST
Identified
We're currently observing slow response times within the Platform's user interface. Please be aware that data processing remains unaffected by this issue.
The cause has been identified to network issues at our provider in Falkenstein, and we are waiting for them to improve the situation.
We apologize for any inconvenience this may cause.