Performance Degradation Notice
Incident Report for Productsup
Resolved
We are happy to announce that our platform has fully restored normal operations. Following our quick resolution of the recent performance issues, all services are now functioning as expected.

We appreciate your patience and understanding during this disruption.
Posted Nov 17, 2023 - 16:47 CET
Monitoring
We have resolved the performance issues that were affecting our platform's speed over the past couple of hours, and we are now monitoring the situation closely to ensure continued stability.
Posted Nov 17, 2023 - 15:42 CET
Investigating
We are experiencing performance issues on our platform, resulting in slower than usual response times over the past couple of hours. Our team is actively investigating the root cause and working diligently to resolve the issue.
Posted Nov 17, 2023 - 14:58 CET
This incident affected: Productsup Platform.