Delayed Processing Runs
Incident Report for Productsup
Postmortem

Last night starting at 12am our main database failed to accept some queries which led to aborted processing runs. We were able to track the error and provide a fix immediately. Failed jobs have been logged and the jobs have been triggered to run again after we were sure the issue was resolved.

Due to that circumstance some jobs had a delay in data delivery.

If you notice one of the following during 12am and 3:30am in the Platform, your site/run was affected and we took care in starting the site again:

  • The import history misses a run in the timeframe
  • The export history misses a run in the timeframe
  • You got a notification that a run did not finish on time when this alert has been configured in the platform monitoring section.

We’re going to implement measures to prevent this issue from happening again.

Posted May 01, 2021 - 11:02 CEST

Resolved
Last night starting at 12am our main database failed to accept some queries which led to aborted processing runs. We were able to track the error and provide a fix immediately. Failed jobs have been logged and the jobs have been triggered to run again after we were sure the issue was resolved.

Due to that circumstance some jobs had a delay in data delivery.

If you notice one of the following during 12am and 3:30am in the Platform, your site/run might be affected and we took care starting the site again:

* The import history misses a run in the timeframe
* The export history misses a run in the timeframe
* You got a notification that a run did not finish on time when this alert has been configured in the platform monitoring section.

We’re going to implement measures to prevent this issue from happening again.
Posted May 01, 2021 - 00:00 CEST